PEC Postecert, protocolli, sicurezza e la scarsa attenzione per l’utente

Premessa doverosa.

Da anni sono un utente Postecert relativamente soddisfatto. Credo che il servizio abbia un rapporto costi-benefici estremamente interessante.

I fatti.

Dal 4 giugno 2019 non ricevo più PEC e dalla settimana scorsa ricevo un errore sul mio iPhone: “Impossibile ricevere posta. Il server mail.postecert.it non risponde.

A volte capita di controllare la posta durante qualche manutenzione sui loro server. Come detto in premessa, visto il costo del servizio è messo in conto che possa saltuariamente succedere visto che non hai siglato SLA stratosferici, ovviamente.

Aspetto. Controllo per giorni e giorni. Stesso messaggio.

Ipotizzo qualche blocco account magari dovuto a qualche tentativo di intrusione così, finalmente, mi decido a verificare l’accesso via web.

Digito https://www.postecert.it e qui inizia la prima sorpresa:


Peccato: non credo che in Poste abbiano bisogno di spiegazioni su come configurare certificati sui servizi pubblicamente esposti ma tant’è.

Procedo sul sito della webmail (qui il certificato è corretto) e mi ritrovo questo messaggio sulla home:

Avviso
A partire dal 1 Luglio 2019, verranno dismessi i protocolli di comunicazione TLS 1.0 e TLS 1.1, deprecati, in favore dell’utilizzo del protocollo TLS 1.2 (già attivo), in aderenza all’innalzamento del livello di sicurezza richiesto dall’Agenzia per l’Italia Digitale a tutti i Gestori PEC.
Pertanto si raccomanda ai clienti di aggiornare il client di posta elettronica, per continuare a fruire del servizio utilizzando la versione più sicura del protocollo di invio dei messaggi PEC

Qualche dubbio inizia a materializzarsi. Qualcosa è cambiata (“già attivo“) anche se la dismissione dei protocolli deprecati è prevista per il 1 Luglio?

Provo ad accedere e realizzo che l’accesso alla casella è garantito e mi ritrovo un messaggio che sul client mobile non ho mai ricevuto.

Il messaggio è datato 19 Giugno 2019:

Gentile cliente,
ti informiamo che a partire dalla mezzanotte del 1 Luglio 2019, saranno innalzati i livelli di sicurezza delle comunicazioni via PEC così come richiesto dall’Agenzia per l’Italia Digitale a tutti i Gestori. Per ogni problema nella ricezione ed invio delle mail PEC, ti raccomandiamo di aggiornare il client di posta elettronica alle versioni più recenti.
 
Per ogni chiarimento o richiesta di assistenza puoi contattare il nostro Call Center al numero verde 803.160, dal lunedì al sabato dalle 8:00 alle 20:00.
 
Poste Italiane

Domanda: perché questo messaggio datato 19 Giugno non è mai stato consegnato sul client mobile?

Anche se ha smesso di funzionare all’improvviso e se tutto sembra correttamente impostato ricontrollo la configurazione e reimposto tutto secondo quanto specificato sul loro sito https://postecert.poste.it/pec/configurazione.shtml

Tutto corretto. Per completezza provo ad effettuare un ulteriore profilo configurando il protocollo POP3 invece di IMAP.

Improvvisamente noto che il servizio via POP3 funziona perfettamente mentre quello IMAP no.

Considerazioni

Non cambio una virgola rispetto a quanto espresso in premessa perché ne sono profondamente convinto. In ogni caso:

  • non capisco perché la mail non riporti la (probabile?) dismissione dell’accesso via IMAP
  • non capisco perché le modifiche siano state apportate PRIMA di assicurarsi che la corretta comunicazione preventiva sia giunta all’utente finale
  • non capisco perché non abbiano riconfigurato il supporto per la nuova versione di TLS anche per l’accesso via IMAP
  • non capisco perché non abbiano aggiornato le pagine della configurazione degli accessi specificando che IMAP non è più utilizzabile
  • non capisco perché se le dismissioni sono previste per il 1 Luglio perché via IMAP non funziona più da settimane ben prima della data comunicata
  • ti raccomandiamo di aggiornare il client di posta elettronica alle versioni più recenti” non significa nulla: il mio client è aggiornatissimo ma ha smesso di funzionare grazie alle loro modifiche e l’utente generico non sempre ha tempo e competenze per verificare se il servizio per cui paga funzioni tramite altro protocollo

Peccato. Bastava veramente poco.

6 thoughts on “PEC Postecert, protocolli, sicurezza e la scarsa attenzione per l’utente

  1. Buonasera,
    io ho lo stesso problema, Lei invece a quanto ho capito è riuscito a risolvere. Ho telefonato al call center delle Poste ma mi hanno risposto che ci voleva un tecnico perchè dovevo modificare una voce del Registro di sistema.. Mi può spiegare per cortesia come è riuscito ad abilitare i nuovi protocolli TLS? Ha riconfigurato tutta la casella della Posta certificata?
    La ringrazio per avermi letta e grazie anticipatamente se potrà aiutarmi…domani riproverò con le Poste nella speranza che ci sia un tecnico
    Chiara

  2. Salve Chiara,
    credo che le abbiano dato una risposta piuttosto sbrigativa e fuorviante.
    Da quello che notai a suo tempo avevano disabilitato il servizio tramite IMAP (c’è poco da configurare lato client, ecco).

    In ogni caso configuri il suo client di posta per consultarlo in POP3 e dovrebbe funzionare.

    Saluti.

    P.S.: questo basandomi su quanto ha detto lei ossia “ho il suo stesso problema” cioè hanno disabilitato o apportato modifiche al servizio IMAP tanto da non renderlo più fruibile.
    Se viceversa lei ha sempre usato POP3 e adesso non riesce più ad autenticarsi potrebbe essere necessario un aggiornamento lato client sui programmi / client/ dispositivi meno recenti.

    Che client usa? Sistema operativo e versione? Senza questi dati, in questo secondo scenario, non posso essere di grande aiuto.

  3. IO invece ho un errore usando pop3 , testato su vari SO e su vari client: user mail locked . Avete avuto questo tipo di esperienza? Sapete se è possibile contattare un vero tecnico di poste e non il call center che risponde senza saperne nulla?
    Grazie

    1. Io proverei a verificare le credenziali di accesso via web e poi aprirei un ticket al supporto nel caso in cui il problema dovesse persistere.
      User mail Locked è decisamente un’altra tipologia di problema.
      Controlla le porte e inprmetro di configurazione del servizio, magari è solo una svista di configurazione.

  4. Mi sento di escludere queste possibilità. Ovviamente la prova della credenziali è già stata fatta, e la configurazione è corretta dal momento che il problema è apparso dal nulla, senza modifiche della configurazione lato client.
    Grazie comunque

    1. Bene.
      Potrebbe essere un lock momentaneo dovuto a qualche attività di manutenzione.
      È meglio sentire l’assistenza.
      Pare facile 😉
      Buona fortuna.
      Facci sapere se vuoi.

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.